Connectivity Issues in Inuvik

Incident Report for IRISTEL

Monitoring

Dear Iristel Customers,

We are currently observing that the affected circuit has been up since 17:38 EDT. However, we have not yet received an official update or confirmation from our upstream carrier regarding the status of their investigation.

We are continuing to monitor the situation closely and are awaiting further information from our upstream carrier. We will provide additional updates as soon as they become available.

Thank you.
Posted Jun 24, 2026 - 23:46 EDT

Update

We are continuing to investigate this issue.
Posted Jun 24, 2026 - 17:35 EDT

Investigating

Dear Iristel Customers,

We would like to inform you that we are experiencing connectivity issues towards location Inuvik, NWT.
We have reached out to our upstream carrier and they informed us that their switching team is investigating this issue.

Impact: Calls in/out in the location may be affected

ETR: Not available at this time.

We apologize for the inconvenience. we will keep you updated.
If you have any questions, please feel free to contact Iristel Support team at 416 800 4747 or support@iristel.com

Thank you.
Posted Jun 24, 2026 - 17:32 EDT
This incident affects: HOSTED PBX and LOCAL ORIGINATION SERVICES (NORTHWEST TERRITORIES).