Connectivity issues towards Valleyfield, QC
Incident Report for IRISTEL
Resolved
Dear Iristel Customers,

The outage has been resolved and all services have been restored to normal operation.

We would like to thank you for your patience and understanding.

Should you have any further questions, please kindly call the support team at 1-416-800-4747 or send an email to support@iristel.com.
Posted May 28, 2020 - 16:34 EDT
Investigating
Dear Iristel Customers,

We would like to inform you that we are experiencing connectivity issues towards Valleyfield location, QC.

Impact: Calls in/out in the location cannot be completed.

ETR: Not available at this time.

We apologize for the inconvenience created.

Should you have any further questions, please kindly call the support team at 1-416-800-4747 or send an email to support@iristel.com.
Posted May 28, 2020 - 11:25 EDT
This incident affected: TOLL FREE SERVICES and ESPRESSODID.