Connectivity issues in Northern Canada
Incident Report for IRISTEL
Resolved
Dear Iristel Customers,

We are pleased to announce that connectivity issue in Northern Canada has been restored, and all impacted services have returned to normal operation.

We sincerely appreciate your patience and understanding during this time.

Restoration time - June 19, 2024 05:41:00 PM EST (approximately)

Thank you for your continued support.

Sincerely,
Iristel NOC
Posted Jul 19, 2024 - 19:28 EDT
Investigating
Dear Iristel Customers,

We are currently experiencing PSTN connectivity issue in Northern Canada.
During this incident, PSTN call completion involving NPA 867 may face challenges.

Start time - 16:37 PM EST

More information to follow.

Regards
Iristel NOC
Posted Jul 19, 2024 - 17:15 EDT
This incident affected: LOCAL ORIGINATION SERVICES (YUKON, NORTHWEST TERRITORIES, NUNAVUT).