The site's connectivity issue has been restored. All impacted services are now operational. If you continue to face challenges in this region, please let Iristel support team know.
Thank you for you patience.
Sincerely, Iristel NOC
Posted Jul 23, 2026 - 16:08 EDT
Investigating
Dear Iristel Customers,
We are investigating a network issue affecting Montreal and Quebec City.
Calls routed through legacy PSTN carriers may be impacted. We will provide updates as soon as more information is available.
Sincerely, Iristel NOC
Posted Jul 23, 2026 - 14:54 EDT
This incident affects: LOCAL ORIGINATION SERVICES (QUEBEC).