Impact: PSTN connectivity in Iqaluit, Nunavut

Incident Report for IRISTEL

Resolved

Dear Iristel Customers,

The issue has been resolved and the stability monitoring of the affected media gateway in the region has been positive with no logs of further downtime. All services have been restored to normal operation since 17th July at 07 PM EST.

We would like to thank you for your patience and understanding.

Regards,
Iristel NOC
Posted Jul 18, 2026 - 19:56 EDT

Monitoring

Dear Iristel Customers,

Our team has implemented corrective action and the affected PSTN media gateway has been restored. We will keep this incident under monitoring to further assess its stability.

Thank you for your patience.

Regards,
Iristel NOC
Posted Jul 18, 2026 - 01:51 EDT

Investigating

Dear Iristel Customers,

Unfortunately, we see the site is down again.
We continue to work with our field ops team to rectify the issue.

Sincerely,
Iristel NOC
Posted Jul 17, 2026 - 16:10 EDT

Monitoring

Dear Iristel Customers,

Please be advised that the recent service interruption has been corrected.
Normal call functionality is fully restored.

We are currently conducting ongoing monitoring to guarantee service reliability.

Sincerely,
Iristel NOC
Posted Jul 17, 2026 - 16:03 EDT

Identified

Dear Iristel Customers,

Our PSTN media gateway in Iqaluit, Nunavut is currently experiencing intermittent connectivity issues.

Impact: This incident affects voice traffic for carriers relying on legacy PSTN connectivity.

Current Status: All other PSTN sites and SIP-based carriers are operating normally.

We will provide updates here as new information becomes available.

Sincerely,
Iristel NOC.
Posted Jul 17, 2026 - 14:07 EDT
This incident affected: LOCAL ORIGINATION SERVICES (NUNAVUT).