Connectivity issues in Iqaluit
Incident Report for IRISTEL
Resolved
Dear Iristel Customers,

All services have been restored to normal operation since 20th May at 02:05 PM EST.

We have reached out to our carrier partners and they concluded that the weather conditions were the source of this issue.

We would like to thank you for your patience and understanding.

Should you have any further questions, please kindly call the support team at 1-416-800-4747 or send an email to support@iristel.com.
Posted May 25, 2020 - 10:35 EDT
Investigating
Dear Iristel Customers,

We are currently experiencing intermittent issues in Iqaluit with data traffic.

At this moment, we do not have an accurate ETR, but be rest assured that we are working actively to restore services back to normal operation.

We thank you for your patience and understanding.

Should you have any further questions, please kindly call the support team at 1-416-800-4747 or send an email to support@iristel.com.
Posted May 20, 2020 - 14:07 EDT
This incident affected: LOCAL ORIGINATION SERVICES (NUNAVUT).