PSTN Connectivity Issue - Val d'Or, Quebec

Incident Report for IRISTEL

Investigating

Dear Iristel customers,

Please be advised that we are currently experiencing an outage in Val d'Or, Quebec.

We suspect the cause is a device failure, and unfortunately, PSTN inbound and outbound calls are impacted.
All other sites remain operational except for this region.

Our engineering teams are sourcing a replacement. ETR is unknown.

Issue Start Time: April 03, 2026 at 1500H

We will keep you posted as we receive additional information, we appreciate your patience.

Regards,
Iristel NOC
Posted Apr 04, 2026 - 19:45 EDT
This incident affects: LOCAL ORIGINATION SERVICES (QUEBEC).