Montreal - Datacenter preventive maintenance part 1

Scheduled for Mar 11, 21:00 EDT  -  Mar 12, 03:00 EDT

Update

We will be undergoing scheduled maintenance during this time.
Posted Mar 06, 2026 - 15:42 EST

Scheduled

Dear Iristel customers,

Our field operations team will make preventive maintenance in our Montreal data center.

Service impact is not expected
Date March 11, 2026
Start time 21:00 EST
Time duration 06 hours.

If you face any challenges after this maintenance window, please contact Iristel support team.

Sincerely,
Iristel NOC
Posted Mar 06, 2026 - 15:29 EST
This scheduled maintenance affects: LOCAL ORIGINATION SERVICES (QUEBEC).