We have been informed that service has been restored and the reported issue appears to be resolved.
Resolution Time(approx.): 08:16 AM EST
Our team will continue to closely monitor the situation to ensure service stability. If you continue to experience any issues, please contact our Support Team for assistance.
Thank you for your patience and understanding.
Best Regards,
Iristel NOC
Posted Jun 04, 2026 - 11:57 EDT
Investigating
Dear Iristel Customers,
Please be advised that we have a connectivity issue in Ste. Agathe QC. Call to and from PSTN in the region may face completion challenges. This is currently under investigation.
Start Time : June 4, 2026 12:17AM EST
Our sincere apologies for the issue and appreciate your cooperation.
Sincerely, Iristel NOC
Posted Jun 04, 2026 - 01:55 EDT
This incident affects: LOCAL ORIGINATION SERVICES (QUEBEC).