We received an update that the incident is most likely attributable to a power interruption brought by a severe storm in the area. We are still confirming the details on the ground and we will keep you updated for any development.
Thank you for your patience and understanding.
Regards, Iristel NOC
Posted Aug 09, 2026 - 23:11 EDT
Investigating
Dear Iristel Customers,
We are currently experiencing a PSTN connectivity issue affecting the Val-d'Or, QC region. During this time, inbound and outbound calls involving PSTN-dependent carriers may fail. All other regions across Canada are operating normally.
Our team is investigating the issue to restore full service as quickly as possible.
Approximate Downtime: August 09, 2026 0938H UTC
We sincerely apologize for the disruption and appreciate your patience.
Sincerely, Iristel NOC
Posted Aug 09, 2026 - 20:30 EDT
This incident affects: LOCAL ORIGINATION SERVICES (QUEBEC).