Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 20, 2025 - 00:00 EST
Scheduled
Dear Iristel Customers,
Iristel's annual holiday embargo restricts network changes to maintain service quality during the period when technical resources are reduced and customer impact from issues would be highest.
Black Out Period
Begins: Saturday, December 20, 2025 (00:00 EST) Ends: Sunday, January 4, 2026 (23:59 EST) All Non-Emergency Network Activity Suspended
Emergency Work Only: Changes will be permitted exclusively for service-affecting outages or critical security issues. Emergency work requires VP approval.
New service activations or customer requests Partial degradation without customer impact Scheduled maintenance or upgrades Configuration optimization or changes
Sincerely, Iristel NOC
Posted Dec 05, 2025 - 15:01 EST
This scheduled maintenance affected: HOSTED PBX and SIP PEERINGS.