Service Outage in Yellowknife, White Horse and Inuvik
Incident Report for IRISTEL
Resolved
Dear Iristel Customers,

We have been informed by our underlying carrier that the splicing of the Fiber is now complete and all services are restored.

Should you have any further questions, please kindly call the support team at 1-416-800-4747 or send an email to support@iristel.com.

Thank you!
Posted Aug 01, 2020 - 09:46 EDT
Investigating
Dear Iristel Customers,

We are currently experiencing a service outage in Yellowknife, White Horse and Inuvik which will affect calls in/out of the mentioned regions at the moment.

We have reached out to our carrier partners for further investigation and resolution to this outage.

At this moment, we do not have an accurate ETR, but be rest assured that we are working actively to restore services back to normal operation.

We thank you for your patience and understanding.

Should you have any further questions, send an email to support@iristel.com.
Posted Jul 31, 2020 - 19:54 EDT
This incident affected: LOCAL ORIGINATION SERVICES (NORTHWEST TERRITORIES).