Service Outage in Yellowknife, White Horse and Inuvik
Incident Report for IRISTEL
Resolved
Dear Iristel Customers,

All services have been restored to normal operation since yesterday.

We would like to thank you for your patience and understanding.

Should you have any further questions, please kindly call the support team at 1-416-800-4747 or send an email to support@iristel.com.
Posted May 22, 2020 - 12:08 EDT
Update
Dear Valued Customers,

We would like to inform you that all services are working as it should.

Also, monitoring will be further performed to ensure no other difficulties are encountered.

An update will be provided as soon as the official RFO will be received from our carrier regarding the technical difficulties they experienced in their core network.

We thank you for your patience and understanding in this matter.

Should you have any further questions, please send an email to support@iristel.com.
Posted May 22, 2020 - 05:12 EDT
Monitoring
The cause of the outage has been identified and resolved by our carrier partner and all services have been restored, although monitoring is currently ongoing.

We appreciate your patience and understanding.

Should you have any further questions, send an email to support@iristel.com.
Posted May 21, 2020 - 15:56 EDT
Investigating
We are currently experiencing a service outage in Yellowknife, White Horse and Inuvik which will affect calls in/out of the mentioned regions at the moment.
We have reached out to our carrier partners for further investigation and resolution to this outage.
At this moment, we do not have an accurate ETR, but be rest assured that we are working actively to restore services back to normal operation.
We thank you for your patience and understanding.
Should you have any further questions, send an email to support@iristel.com.
Posted May 21, 2020 - 11:34 EDT
This incident affected: LOCAL ORIGINATION SERVICES (YUKON, NORTHWEST TERRITORIES).