Connectivity issues towards St. Thomas, Ontario
Incident Report for IRISTEL
Resolved
Dear Iristel Customers,

We would like to inform you that all services have been restored to normal operation.

We thank you for your patience and understanding.

Should you have any further questions, please kindly call the support team at 1-416-800-4747 or send an email to support@iristel.com.
Posted Oct 18, 2020 - 10:36 EDT
Investigating
Dear Valued Customers,

We would like to inform you that we are currently experiencing network connectivity issues towards St. Thomas, Ontario at this moment.

Investigations are ongoing and updates would be provided very soon.

There is currently No ETR at this moment, however we will notify you once everything is back in service.

We would like to thank you for your patience and understanding.

Should you have any further questions, please kindly call the support team at 1-416-800-4747 or send an email to support@iristel.com.
Posted Oct 18, 2020 - 07:14 EDT
This incident affected: LOCAL ORIGINATION SERVICES (ONTARIO).